CVE-2020-14349

NameCVE-2020-14349
DescriptionIt was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly sanitize the search_path during logical replication. An authenticated attacker could use this flaw in an attack similar to CVE-2018-1058, in order to execute arbitrary SQL command in the context of the user used for replication.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-11 (PTS)buster11.9-0+deb10u1fixed
buster (security)11.7-0+deb10u1vulnerable
postgresql-12 (PTS)bullseye, sid12.4-1fixed
postgresql-9.6 (PTS)stretch9.6.17-0+deb9u1fixed
stretch (security)9.6.19-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-11sourcebuster11.9-0+deb10u1
postgresql-11source(unstable)(unfixed)
postgresql-12source(unstable)12.4-1
postgresql-9.6source(unstable)(not affected)

Notes

- postgresql-9.6 <not-affected> (Vulnerable code introduced later)
https://www.postgresql.org/about/news/2060/
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=11da97024abbe76b8c81e3f2375b2a62e9717c67
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=cec57b1a0fbcd3833086ba686897c5883e0a2afc

Search for package or bug name: Reporting problems