CVE-2020-14350

NameCVE-2020-14350
DescriptionIt was found that some PostgreSQL extensions did not use search_path safely in their installation script. An attacker with sufficient privileges could use this flaw to trick an administrator into executing a specially crafted script, during the installation or update of such extension. This affects PostgreSQL versions before 12.4, before 11.9, before 10.14, before 9.6.19, and before 9.5.23.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2331-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-11 (PTS)buster11.9-0+deb10u1fixed
buster (security)11.7-0+deb10u1vulnerable
postgresql-12 (PTS)bullseye, sid12.4-1fixed
postgresql-9.6 (PTS)stretch9.6.17-0+deb9u1vulnerable
stretch (security)9.6.19-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-11sourcebuster11.9-0+deb10u1
postgresql-11source(unstable)(unfixed)
postgresql-12source(unstable)12.4-1
postgresql-9.6sourcestretch9.6.19-0+deb9u1DLA-2331-1
postgresql-9.6source(unstable)(unfixed)

Notes

https://www.postgresql.org/about/news/2060/
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=7eeb1d9861b0a3f453f8b31c7648396cdd7f1e59

Search for package or bug name: Reporting problems