CVE-2020-14374

NameCVE-2020-14374
DescriptionA flaw was found in dpdk in versions before 18.11.10 and before 19.11.5. A flawed bounds checking in the copy_data function leads to a buffer overflow allowing an attacker in a virtual machine to write arbitrary data to any address in the vhost_crypto application. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs971269

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpdk (PTS)stretch (security), stretch16.11.11-1+deb9u2vulnerable
buster18.11.11-1~deb10u1fixed
buster (security)18.11.6-1~deb10u2vulnerable
bullseye20.11-2fixed
sid20.11-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpdksourcebuster18.11.10-1~deb10u1
dpdksource(unstable)19.11.5-1971269

Notes

[stretch] - dpdk <no-dsa> (Minor issue)
https://bugs.dpdk.org/show_bug.cgi?id=272

Search for package or bug name: Reporting problems