CVE-2020-14377

NameCVE-2020-14377
DescriptionA flaw was found in dpdk in versions before 18.11.10 and before 19.11.5. A complete lack of validation of attacker-controlled parameters can lead to a buffer over read. The results of the over read are then written back to the guest virtual machine memory. This vulnerability can be used by an attacker in a virtual machine to read significant amounts of host memory. The highest threat from this vulnerability is to data confidentiality and system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs971269

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpdk (PTS)stretch (security), stretch16.11.11-1+deb9u2vulnerable
buster18.11.8-1~deb10u1vulnerable
buster (security)18.11.6-1~deb10u2vulnerable
bullseye, sid19.11.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpdksource(unstable)19.11.5-1971269

Notes

[buster] - dpdk <no-dsa> (Minor issue)
[stretch] - dpdk <no-dsa> (Minor issue)
https://bugs.dpdk.org/show_bug.cgi?id=272

Search for package or bug name: Reporting problems