CVE-2020-14378

NameCVE-2020-14378
DescriptionAn integer underflow in dpdk versions before 18.11.10 and before 19.11.5 in the `move_desc` function can lead to large amounts of CPU cycles being eaten up in a long running loop. An attacker could cause `move_desc` to get stuck in a 4,294,967,295-count iteration loop. Depending on how `vhost_crypto` is being used this could prevent other VMs or network tasks from being serviced by the busy DPDK lcore for an extended period.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs971269

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpdk (PTS)stretch, stretch (security)16.11.11-1+deb9u2fixed
buster18.11.11-1~deb10u1fixed
buster (security)18.11.6-1~deb10u2vulnerable
bullseye20.11.4-2~deb11u1fixed
bullseye (security)20.11.5-1~deb11u1fixed
bookworm, sid20.11.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpdksourcestretch(not affected)
dpdksourcebuster18.11.10-1~deb10u1
dpdksource(unstable)19.11.5-1971269

Notes

[stretch] - dpdk <not-affected> (vhost_crypto introduced in v18.05-rc1)
https://bugs.dpdk.org/show_bug.cgi?id=272
https://git.dpdk.org/dpdk-stable/commit/?id=7a5af91f8bf46f121cc1a7873045ef37f63d56c2 (v18.11.10)
Introduced by: https://git.dpdk.org/dpdk-stable/commit/?id=fd9dd27602a6494663ace53f0d52122ed9f0de1c (v18.11.1-rc1)

Search for package or bug name: Reporting problems