CVE-2020-14402

NameCVE-2020-14402
DescriptionAn issue was discovered in LibVNCServer before 0.9.13. libvncserver/corre.c allows out-of-bounds access via encodings.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2264-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)stretch0.9.11+dfsg-1.3~deb9u4vulnerable
stretch (security)0.9.11+dfsg-1.3~deb9u1vulnerable
buster0.9.11+dfsg-1.3+deb10u3vulnerable
bullseye, sid0.9.13+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u8DLA-2264-1
libvncserversource(unstable)0.9.13+dfsg-1

Notes

https://github.com/LibVNC/libvncserver/commit/74e8a70f2c9a5248d6718ce443e07c7ed314dfff

Search for package or bug name: Reporting problems