CVE-2020-16042

NameCVE-2020-16042
DescriptionUninitialized Use in V8 in Google Chrome prior to 87.0.4280.88 allowed a remote attacker to obtain potentially sensitive information from process memory via a crafted HTML page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2496-1, DLA-2497-1, DSA-4813-1, DSA-4815-1, DSA-4824-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)stretch (security), stretch73.0.3683.75-1~deb9u1vulnerable
buster88.0.4324.182-1~deb10u1fixed
buster (security)89.0.4389.114-1~deb10u1fixed
bullseye, sid89.0.4389.114-1fixed
firefox (PTS)sid87.0-2fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1vulnerable
stretch (security)78.9.0esr-1~deb9u1fixed
buster78.8.0esr-1~deb10u1fixed
buster (security)78.9.0esr-1~deb10u1fixed
bullseye, sid78.9.0esr-1fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1vulnerable
stretch (security)1:78.9.0-1~deb9u1fixed
buster1:78.6.0-1~deb10u1fixed
buster (security)1:78.9.0-1~deb10u1fixed
bullseye, sid1:78.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsourcestretch(unfixed)end-of-life
chromiumsourcebuster87.0.4280.88-0.4~deb10u1DSA-4824-1
chromiumsource(unstable)87.0.4280.88-0.1
firefoxsource(unstable)84.0-1
firefox-esrsourcestretch78.6.0esr-1~deb9u1DLA-2496-1
firefox-esrsourcebuster78.6.0esr-1~deb10u1DSA-4813-1
firefox-esrsource(unstable)78.6.0esr-1
thunderbirdsourcestretch1:78.6.0-1~deb9u1DLA-2497-1
thunderbirdsourcebuster1:78.6.0-1~deb10u1DSA-4815-1
thunderbirdsource(unstable)1:78.6.0-1

Notes

[stretch] - chromium <end-of-life> (see DSA 4562)
https://www.mozilla.org/en-US/security/advisories/mfsa2020-54/#CVE-2020-16042
https://www.mozilla.org/en-US/security/advisories/mfsa2020-55/#CVE-2020-16042
https://www.mozilla.org/en-US/security/advisories/mfsa2020-56/#CVE-2020-16042

Search for package or bug name: Reporting problems