CVE-2020-18430

NameCVE-2020-18430
Descriptiontinyexr 0.9.5 was discovered to contain an array index error in the tinyexr::DecodeEXRImage component, which can lead to a denial of service (DOS).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tinyexr (PTS)bullseye1.0.0+dfsg-1fixed
bookworm1.0.1+dfsg-2fixed
sid1.0.1+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tinyexrsource(unstable)(not affected)

Notes

- tinyexr <not-affected> (Fixed with initial upload to Debian)
https://github.com/ChijinZ/security_advisories/tree/master/tinyexr_65f9859#cve-2020-18430-out-of-memory-in-function-tinyexrdecodeexrimage-tinyexrh11046
https://github.com/syoyo/tinyexr/issues/108

Search for package or bug name: Reporting problems