CVE-2020-1935

NameCVE-2020-1935
DescriptionIn Apache Tomcat 9.0.0.M1 to 9.0.30, 8.5.0 to 8.5.50 and 7.0.0 to 7.0.99 the HTTP header parsing code used an approach to end-of-line parsing that allowed some invalid HTTP headers to be parsed as valid. This led to a possibility of HTTP Request Smuggling if Tomcat was located behind a reverse proxy that incorrectly handled the invalid Transfer-Encoding header in a particular manner. Such a reverse proxy is considered unlikely.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2133-1, DLA-2209-1, DSA-4673-1, DSA-4680-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat7 (PTS)jessie7.0.56-3+deb8u11vulnerable
jessie (security)7.0.56-3+really7.0.100-1+deb8u1fixed
stretch7.0.75-1vulnerable
tomcat8 (PTS)jessie8.0.14-1+deb8u11vulnerable
jessie (security)8.0.14-1+deb8u17fixed
stretch8.5.50-0+deb9u1vulnerable
stretch (security)8.5.54-0+deb9u1fixed
tomcat9 (PTS)buster9.0.16-4vulnerable
buster (security)9.0.31-1~deb10u1fixed
bullseye, sid9.0.35-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat7source(unstable)(unfixed)
tomcat7sourcejessie7.0.56-3+really7.0.100-1DLA-2133-1
tomcat8source(unstable)(unfixed)
tomcat8sourcejessie8.0.14-1+deb8u17DLA-2209-1
tomcat8sourcestretch8.5.54-0+deb9u1DSA-4673-1
tomcat9source(unstable)9.0.31-1
tomcat9sourcebuster9.0.31-1~deb10u1DSA-4680-1

Notes

https://github.com/apache/tomcat/commit/8bfb0ff7f25fe7555a5eb2f7984f73546c11aa26 (9.0.31)
https://github.com/apache/tomcat/commit/8fbe2e962f0ea138d92361921643fe5abe0c4f56 (8.5.51)
https://github.com/apache/tomcat/commit/702bf15bea292915684d931526d95d4990b2e73d (7.0.100)

Search for package or bug name: Reporting problems