CVE-2020-21428

NameCVE-2020-21428
DescriptionBuffer Overflow vulnerability in function LoadRGB in PluginDDS.cpp in FreeImage 3.18.0 allows remote attackers to run arbitrary code and cause other impacts via crafted image file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3662-1, DSA-5579-1
Debian Bugs1051738

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeimage (PTS)buster3.18.0+ds2-1+deb10u1vulnerable
buster (security)3.18.0+ds2-1+deb10u2fixed
bullseye (security), bullseye3.18.0+ds2-6+deb11u1fixed
bookworm, bookworm (security)3.18.0+ds2-9+deb12u1fixed
sid, trixie3.18.0+ds2-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeimagesourcebuster3.18.0+ds2-1+deb10u2DLA-3662-1
freeimagesourcebullseye3.18.0+ds2-6+deb11u1DSA-5579-1
freeimagesourcebookworm3.18.0+ds2-9+deb12u1DSA-5579-1
freeimagesource(unstable)3.18.0+ds2-101051738

Notes

https://sourceforge.net/p/freeimage/bugs/299/
Fixed with r1877 from http://svn.code.sf.net/p/freeimage/svn/FreeImage/

Search for package or bug name: Reporting problems