CVE-2020-21595

NameCVE-2020-21595
Descriptionlibde265 v1.0.4 contains a heap buffer overflow in the mc_luma function, which can be exploited via a crafted a file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1014999

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libde265 (PTS)buster1.0.3-1vulnerable
bullseye1.0.8-1vulnerable
bookworm, sid1.0.9-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libde265source(unstable)(unfixed)1014999

Notes

[bullseye] - libde265 <postponed> (Minor issue, revisit when fixed upstream)
[buster] - libde265 <postponed> (Minor issue, revisit when fixed upstream)
[stretch] - libde265 <postponed> (Minor issue, revisit when fixed upstream)
https://github.com/strukturag/libde265/issues/239

Search for package or bug name: Reporting problems