CVE-2020-22037

NameCVE-2020-22037
DescriptionA Denial of Service vulnerability exists in FFmpeg 4.2 due to a memory leak in avcodec_alloc_context3 at options.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2818-1, DSA-4990-1, DSA-4998-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1vulnerable
stretch (security)7:3.2.16-1+deb9u1fixed
buster7:4.1.6-1~deb10u1vulnerable
buster (security)7:4.1.8-0+deb10u1fixed
bullseye7:4.3.2-0+deb11u2vulnerable
bullseye (security)7:4.3.3-0+deb11u1fixed
bookworm, sid7:4.4.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcestretch7:3.2.16-1+deb9u1DLA-2818-1
ffmpegsourcebuster7:4.1.8-0+deb10u1DSA-4990-1
ffmpegsourcebullseye7:4.3.3-0+deb11u1DSA-4998-1
ffmpegsource(unstable)7:4.4.1-1unimportant

Notes

https://trac.ffmpeg.org/ticket/8281
https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=7bba0dd6382e30d646cb406034a66199e071d713

Search for package or bug name: Reporting problems