CVE-2020-24027

NameCVE-2020-24027
DescriptionIn Live Networks, Inc., liblivemedia version 20200625, there is a potential buffer overflow bug in the server handling of a RTSP "PLAY" command, when the command specifies seeking by absolute time.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblivemedia (PTS)stretch (security), stretch2016.11.28-1+deb9u2vulnerable
buster2018.11.26-1.1vulnerable
bullseye, sid2020.01.19-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblivemediasource(unstable)(unfixed)

Notes

http://lists.live555.com/pipermail/live-devel/2020-July/021662.html
Fixed in 2020.07.09 upstream, cf.
http://www.live555.com/liveMedia/public/changelog.txt

Search for package or bug name: Reporting problems