DescriptionLuaJIT through 2.1.0-beta3 has an out-of-bounds read in lj_err_run in lj_err.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
luajit (PTS)stretch2.0.4+dfsg-1vulnerable
stretch (security)2.0.4+dfsg-1+deb9u1vulnerable
bullseye, sid, buster2.1.0~beta3+dfsg-5.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs

No security impact, only "exploitable" with untrusted Lua code

Search for package or bug name: Reporting problems