CVE-2020-24660

NameCVE-2020-24660
DescriptionAn issue was discovered in LemonLDAP::NG through 2.0.8, when NGINX is used. An attacker may bypass URL-based access control to protected Virtual Hosts by submitting a non-normalized URI. This also affects versions before 0.5.2 of the "Lemonldap::NG handler for Node.js" package.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2367-1, DSA-4762-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lemonldap-ng (PTS)stretch1.9.7-3+deb9u2vulnerable
stretch (security)1.9.7-3+deb9u4fixed
buster, buster (security)2.0.2+ds-7+deb10u5fixed
bullseye, sid2.0.9+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lemonldap-ngsourcestretch1.9.7-3+deb9u4DLA-2367-1
lemonldap-ngsourcebuster2.0.2+ds-7+deb10u5DSA-4762-1
lemonldap-ngsource(unstable)2.0.9+ds-1

Notes

https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/2290

Search for package or bug name: Reporting problems