CVE-2020-24972

NameCVE-2020-24972
DescriptionThe Kleopatra component before 3.1.12 (and before 20.07.80) for GnuPG allows remote attackers to execute arbitrary code because openpgp4fpr: URLs are supported without safe handling of command-line options. The Qt platformpluginpath command-line option can be used to load an arbitrary DLL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kleopatra (PTS)stretch4:16.04.2-2fixed
buster4:18.08.3-1vulnerable
bullseye, sid4:20.04.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kleopatrasourcestretch(not affected)
kleopatrasource(unstable)(unfixed)

Notes

[buster] - kleopatra <no-dsa> (Minor issue)
[stretch] - kleopatra <not-affected> (Vulnerable code added to Debian in version 4:18.07.90-1)
https://dev.gnupg.org/rKLEOPATRAb4bd63c1739900d94c04da03045e9445a5a5f54b
https://security.gentoo.org/glsa/202008-21
Added in https://dev.gnupg.org/rKLEOPATRAd1cd40bae47eb349e14750601223b6b5d9f71940 (v18.07.80+)

Search for package or bug name: Reporting problems