DescriptionThe Kleopatra component before 3.1.12 (and before 20.07.80) for GnuPG allows remote attackers to execute arbitrary code because openpgp4fpr: URLs are supported without safe handling of command-line options. The Qt platformpluginpath command-line option can be used to load an arbitrary DLL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kleopatra (PTS)stretch4:16.04.2-2fixed
bullseye, sid4:20.08.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kleopatrasourcestretch(not affected)


[buster] - kleopatra <no-dsa> (Minor issue)
[stretch] - kleopatra <not-affected> (Vulnerable code added to Debian in version 4:18.07.90-1)
Introduced via: (v18.07.80+)
Fixed by:

Search for package or bug name: Reporting problems