CVE-2020-25097

NameCVE-2020-25097
DescriptionAn issue was discovered in Squid through 4.13 and 5.x through 5.0.4. Due to improper input validation, it allows a trusted client to perform HTTP Request Smuggling and access services otherwise forbidden by the security controls. This occurs for certain uri_whitespace configuration settings.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2598-1, DSA-4873-1
NVD severitymedium
Debian Bugs985068

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, buster (security)4.6-1+deb10u6fixed
bullseye, sid4.13-10fixed
squid3 (PTS)stretch3.5.23-5+deb9u1vulnerable
stretch (security)3.5.23-5+deb9u7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsourcebuster4.6-1+deb10u5DSA-4873-1
squidsource(unstable)4.13-8985068
squid3sourcestretch3.5.23-5+deb9u6DLA-2598-1
squid3source(unstable)(unfixed)

Notes

https://github.com/squid-cache/squid/security/advisories/GHSA-jvf6-h9gj-pmj6
Squid 4: http://www.squid-cache.org/Versions/v4/changesets/SQUID-2020_11.patch

Search for package or bug name: Reporting problems