DescriptionAn issue was discovered in InspIRCd 2 before 2.0.29 and 3 before 3.6.0. The pgsql module contains a use after free vulnerability. When combined with the sqlauth or sqloper modules, this vulnerability can be used for remote crashing of an InspIRCd server by any user able to connect to a server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2375-1, DSA-4764-1
NVD severitymedium
Debian Bugs960650

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
inspircd (PTS)stretch2.0.23-2vulnerable
stretch (security)2.0.23-2+deb9u1fixed
buster, buster (security)2.0.27-1+deb10u1fixed
bookworm, sid, bullseye3.8.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs

Notes (v2) (v2) (v2) (v3) (v3) (v3)

Search for package or bug name: Reporting problems