|Description||A flaw was found in the HDLC_PPP module of the Linux kernel in versions before 5.9-rc7. Memory corruption and a read overflow is caused by improper input validation in the ppp_cp_parse_cr function which can cause the system to crash or cause a denial of service. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)|
|References||DLA-2417-1, DLA-2420-1, DSA-4774-1|
Vulnerable and fixed packages
The table below lists information on source packages.
|buster, buster (security)||4.19.171-2||fixed|
|linux-4.19 (PTS)||stretch (security)||4.19.171-2~deb9u1||fixed|
The information below is based on the following data on fixed versions.