CVE-2020-25643

NameCVE-2020-25643
DescriptionA flaw was found in the HDLC_PPP module of the Linux kernel in versions before 5.9-rc7. Memory corruption and a read overflow is caused by improper input validation in the ppp_cp_parse_cr function which can cause the system to crash or cause a denial of service. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2417-1, DSA-4774-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.210-1+deb9u1vulnerable
buster4.19.146-1vulnerable
buster (security)4.19.152-1fixed
bullseye, sid5.9.1-1fixed
linux-4.19 (PTS)stretch (security)4.19.152-1~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster4.19.152-1DSA-4774-1
linuxsource(unstable)5.8.14-1
linux-4.19sourcestretch4.19.152-1~deb9u1DLA-2417-1

Notes

https://git.kernel.org/linus/66d42ed8b25b64eb63111a2b8582c5afc8bf1105

Search for package or bug name: Reporting problems