CVE-2020-25695

NameCVE-2020-25695
DescriptionA flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2478-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-11 (PTS)buster11.13-0+deb10u1fixed
buster (security)11.14-0+deb10u1fixed
postgresql-13 (PTS)bullseye13.4-0+deb11u1fixed
bullseye (security)13.5-0+deb11u1fixed
bookworm13.4-3fixed
postgresql-9.6 (PTS)stretch9.6.17-0+deb9u1vulnerable
stretch (security)9.6.24-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-11sourcebuster11.10-0+deb10u1
postgresql-11source(unstable)(unfixed)
postgresql-12source(unstable)(unfixed)
postgresql-13source(unstable)13.1-1
postgresql-9.6sourcestretch9.6.20-0+deb9u1DLA-2478-1
postgresql-9.6source(unstable)(unfixed)

Notes

https://www.postgresql.org/about/news/postgresql-131-125-1110-1015-9620-and-9524-released-2111/
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=aefc625dedae52073e7d279feb43f6255f992ea7 (REL9_5_STABLE)

Search for package or bug name: Reporting problems