CVE-2020-26117

NameCVE-2020-26117
DescriptionIn rfb/CSecurityTLS.cxx and rfb/CSecurityTLS.java in TigerVNC before 1.11.0, viewers mishandle TLS certificate exceptions. They store the certificates as authorities, meaning that the owner of a certificate could impersonate any server after a client had added an exception.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2396-1
Debian Bugs971272

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tigervnc (PTS)buster1.9.0+dfsg-3+deb10u3fixed
bullseye1.11.0+dfsg-2+deb11u1fixed
bookworm, sid1.12.0+dfsg-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tigervncsourcestretch1.7.0+dfsg-7+deb9u2DLA-2396-1
tigervncsourcebuster1.9.0+dfsg-3+deb10u3
tigervncsource(unstable)1.10.1+dfsg-9971272

Notes

https://bugzilla.opensuse.org/show_bug.cgi?id=1176733
https://github.com/TigerVNC/tigervnc/commit/20dea801e747318525a5859fe4f37c52b05310cb (v1.11.0)
https://github.com/TigerVNC/tigervnc/commit/7399eab79a4365434d26494fa1628ce1eb91562b (v1.11.0)
https://github.com/TigerVNC/tigervnc/commit/b30f10c681ec87720cff85d490f67098568a9cba (master)
https://github.com/TigerVNC/tigervnc/commit/f029745f63ac7d22fb91639b2cb5b3ab56134d6e (master)

Search for package or bug name: Reporting problems