CVE-2020-27507

NameCVE-2020-27507
DescriptionThe Kamailio SIP before 5.5.0 server mishandles INVITE requests with duplicated fields and overlength tag, leading to a buffer overflow that crashes the server or possibly have unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3438-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kamailio (PTS)bullseye5.4.4-1fixed
bookworm5.6.3-2fixed
sid5.8.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kamailiosourcebuster5.2.1-1+deb10u1DLA-3438-1
kamailiosource(unstable)5.4.2-1

Notes

https://github.com/kamailio/kamailio/issues/2503
https://github.com/kamailio/kamailio/commit/f57c900b438f3233fa1e9a9d3ca8cd383a30baa6 (5.4.2) (5.4 branch)
https://github.com/kamailio/kamailio/commit/ada3701d22b1fd579f06b4f54fa695fa988e685f (5.5.0) (master branch)

Search for package or bug name: Reporting problems