CVE-2020-27637

NameCVE-2020-27637
DescriptionThe R programming languageā€™s default package manager CRAN is affected by a path traversal vulnerability that can lead to server compromise. This vulnerability affects packages installed via the R CMD install cli command or the install.packages() function from the interpreter. Update to version 4.0.3
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
r-base (PTS)stretch3.3.3-1vulnerable
buster3.5.2-1vulnerable
bullseye, sid4.0.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
r-basesource(unstable)4.0.3-1

Notes

[buster] - r-base <no-dsa> (Minor issue)
[stretch] - r-base <no-dsa> (Minor issue)
https://labs.bishopfox.com/advisories/cran-version-4.0.2
check details

Search for package or bug name: Reporting problems