CVE-2020-27745

NameCVE-2020-27745
DescriptionSlurm before 19.05.8 and 20.x before 20.02.6 has an RPC Buffer Overflow in the PMIx MPI plugin.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4841-1
NVD severitymedium
Debian Bugs974721

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)stretch16.05.9-1+deb9u4vulnerable
stretch (security)16.05.9-1+deb9u2vulnerable
buster, buster (security)18.08.5.2-1+deb10u2fixed
slurm-wlm (PTS)bullseye, sid20.11.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsourcebuster18.08.5.2-1+deb10u2DSA-4841-1
slurm-llnlsource(unstable)(unfixed)974721
slurm-wlmsource(unstable)(not affected)

Notes

- slurm-wlm <not-affected> (Fixed with first upload to Debian with renamed source package)
[stretch] - slurm-llnl <no-dsa> (Minor issue)
https://www.schedmd.com/news.php?id=240
https://lists.schedmd.com/pipermail/slurm-announce/2020/000045.html
https://github.com/SchedMD/slurm/commit/c3142dd87e06621ff148791c3d2f298b5c0b3a81
slurm-wlm/20.02.6-1 changed the source package name and included the fix

Search for package or bug name: Reporting problems