CVE-2020-27827

NameCVE-2020-27827
Descriptionlldp: avoid memory leak from bad packets
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs980132

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lldpd (PTS)stretch0.9.6-1vulnerable
buster1.0.3-1vulnerable
bullseye1.0.7-1vulnerable
sid1.0.8-1fixed
openvswitch (PTS)stretch2.6.2~pre+git20161223-3vulnerable
buster2.10.0+2018.08.28+git.8ca7c82b7d+ds1-12+deb10u2vulnerable
bullseye2.15.0~git20210104.def6eb1ea+dfsg1-3vulnerable
sid2.15.0~git20210104.def6eb1ea+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lldpdsource(unstable)1.0.8-1
openvswitchsource(unstable)2.15.0~git20210104.def6eb1ea+dfsg1-4980132

Notes

[buster] - lldpd <no-dsa> (Minor issue)
https://github.com/openvswitch/ovs/pull/337
https://github.com/lldpd/lldpd/commit/a8d3c90feca548fc0656d95b5d278713db86ff61
https://mail.openvswitch.org/pipermail/ovs-announce/2021-January/000269.html
https://github.com/openvswitch/ovs/commit/78e712c0b1dacc2f12d2a03d98f083d8672867f0

Search for package or bug name: Reporting problems