CVE-2020-28030

NameCVE-2020-28030
DescriptionIn Wireshark 3.2.0 to 3.2.7, the GQUIC dissector could crash. This was addressed in epan/dissectors/packet-gquic.c by correcting the implementation of offset advancement.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs974689

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch2.6.7-1~deb9u1vulnerable
stretch (security)2.6.8-1.1~deb9u1vulnerable
buster2.6.8-1.1vulnerable
bullseye3.2.7-1vulnerable
sid3.2.8-0.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)(unfixed)974689

Notes

[buster] - wireshark <postponed> (Minor issue, can be fixed along in next DSA)
https://gitlab.com/wireshark/wireshark/-/commit/b287e7165e8aa89cde6ae37e7c257c5d87d16b9b
https://gitlab.com/wireshark/wireshark/-/issues/16887
https://www.wireshark.org/security/wnpa-sec-2020-15.html

Search for package or bug name: Reporting problems