CVE-2020-28984

NameCVE-2020-28984
Descriptionprive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2505-1, DSA-4798-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)stretch3.1.4-4~deb9u3vulnerable
stretch (security)3.1.4-4~deb9u4+deb9u1fixed
buster, buster (security)3.2.4-1+deb10u4fixed
bookworm, bullseye, sid3.2.11-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsourcestretch3.1.4-4~deb9u4DLA-2505-1
spipsourcebuster3.2.4-1+deb10u3DSA-4798-1
spipsource(unstable)3.2.8-1

Notes

https://git.spip.net/spip/spip/commit/ae4267eba1022dabc12831ddb021c5d6e09040f8

Search for package or bug name: Reporting problems