CVE-2020-29129

NameCVE-2020-29129
Descriptionncsi.c in libslirp through 4.3.1 has a buffer over-read because it tries to read a certain amount of header data even if that exceeds the total packet length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libslirp (PTS)bullseye4.4.0-1+deb11u2fixed
bookworm, sid4.6.1-1fixed
qemu (PTS)stretch1:2.8+dfsg-6+deb9u9fixed
stretch (security)1:2.8+dfsg-6+deb9u16fixed
buster, buster (security)1:3.1+dfsg-8+deb10u8vulnerable
bullseye1:5.2+dfsg-11fixed
bullseye (security)1:5.2+dfsg-11+deb11u1fixed
bookworm, sid1:6.1+dfsg-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libslirpsource(unstable)4.4.0-1
qemusourcestretch(not affected)
qemusource(unstable)1:4.1-2

Notes

[buster] - qemu <postponed> (Fix along in future DSA)
[stretch] - qemu <not-affected> (Vulnerable code introduced later)
https://gitlab.freedesktop.org/slirp/libslirp/-/commit/2e1dcbc0c2af64fcb17009eaf2ceedd81be2b27f (v4.4.0)
qemu 1:4.1-2 switched to system libslirp, marking that version as fixed.
NC-SI introduced in: https://git.qemu.org/?p=qemu.git;a=commit;h=47bb83cad45eb7ce194a8ffd18f73c98edb46aec (QEMU v2.10)
https://github.com/rootless-containers/slirp4netns/security/advisories/GHSA-2j37-w439-87q3

Search for package or bug name: Reporting problems