CVE-2020-29663

NameCVE-2020-29663
DescriptionIcinga 2 v2.8.0 through v2.11.7 and v2.12.2 has an issue where revoked certificates due for renewal will automatically be renewed, ignoring the CRL. This issue is fixed in Icinga 2 v2.11.8 and v2.12.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icinga2 (PTS)stretch2.6.0-2+deb9u1fixed
buster2.10.3-2+deb10u1vulnerable
bullseye, sid2.12.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icinga2sourcestretch(not affected)
icinga2source(unstable)2.12.3-1

Notes

[buster] - icinga2 <no-dsa> (Minor issue)
[stretch] - icinga2 <not-affected> (Vulnerable code not present)
https://github.com/Icinga/icinga2/security/advisories/GHSA-pcmr-2p2f-r7j6
https://github.com/Icinga/icinga2/commit/abbd7d5494369af8bbf8fc12f5dc1a0f05a1f817
https://github.com/Icinga/icinga2/commit/cae22a89da9e6a381904c3b207e5a3f93f6ed838

Search for package or bug name: Reporting problems