CVE-2020-36471

NameCVE-2020-36471
DescriptionAn issue was discovered in the generator crate before 0.7.0 for Rust. It does not ensure that a function (for yielding values) has Send bounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs992047

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-generator (PTS)bookworm, sid, bullseye0.6.20-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-generatorsource(unstable)(unfixed)992047

Notes

[bullseye] - rust-generator <no-dsa> (Minor issue)
https://rustsec.org/advisories/RUSTSEC-2020-0151.html

Search for package or bug name: Reporting problems