CVE-2020-4049

NameCVE-2020-4049
DescriptionIn affected versions of WordPress, when uploading themes, the name of the theme folder can be crafted in a way that could lead to JavaScript execution in /wp-admin on the themes page. This does require an admin to upload the theme, and is low severity self-XSS. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2269-1, DSA-4709-1
NVD severitylow
Debian Bugs962685

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u5vulnerable
stretch (security)4.7.5+dfsg-2+deb9u6vulnerable
buster5.0.4+dfsg1-1+deb10u1vulnerable
buster (security)5.0.10+dfsg1-0+deb10u1fixed
bullseye, sid5.4.2+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)5.4.2+dfsg1-1962685
wordpresssourcebuster5.0.10+dfsg1-0+deb10u1DSA-4709-1
wordpresssourcejessie4.1.31+dfsg-0+deb8u1DLA-2269-1

Notes

https://core.trac.wordpress.org/changeset/47950
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-87h4-phjv-rm6p
https://github.com/WordPress/wordpress-develop/commit/404f397b4012fd9d382e55bf7d206c1317f01148

Search for package or bug name: Reporting problems