CVE-2020-4067

NameCVE-2020-4067
DescriptionIn coturn before version 4.5.1.3, there is an issue whereby STUN/TURN response buffer is not initialized properly. There is a leak of information between different client connections. One client (an attacker) could use their connection to intelligently query coturn to get interesting bytes in the padding bytes from the connection of another client. This has been fixed in 4.5.1.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2271-1, DSA-4711-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
coturn (PTS)stretch (security), stretch4.5.0.5-1+deb9u2fixed
buster, buster (security)4.5.1.1-1.1+deb10u1fixed
bullseye, sid4.5.1.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
coturnsourcejessie4.2.1.2-1+deb8u2DLA-2271-1
coturnsourcestretch4.5.0.5-1+deb9u2DSA-4711-1
coturnsourcebuster4.5.1.1-1.1+deb10u1DSA-4711-1
coturnsource(unstable)4.5.1.3-1

Notes

https://github.com/coturn/coturn/security/advisories/GHSA-c8r8-8vp5-6gcm
https://github.com/coturn/coturn/commit/170da1140797748ae85565b5a93a2e35e7b07b6a

Search for package or bug name: Reporting problems