CVE-2020-5211

NameCVE-2020-5211
DescriptionIn NetHack before 3.6.5, an invalid extended command in value for the AUTOCOMPLETE configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nethack (PTS)jessie3.4.3-15vulnerable
stretch3.6.0-4vulnerable
buster, bullseye, sid3.6.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nethacksource(unstable)(unfixed)unimportant

Notes

https://github.com/NetHack/NetHack/security/advisories/GHSA-r788-4jf4-r9f7
Negligible security impact

Search for package or bug name: Reporting problems