CVE-2020-5213

NameCVE-2020-5213
DescriptionIn NetHack before 3.6.5, too long of a value for the SYMBOL configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nethack (PTS)jessie3.4.3-15vulnerable
stretch3.6.0-4vulnerable
sid, buster3.6.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nethacksource(unstable)(unfixed)unimportant

Notes

https://github.com/NetHack/NetHack/security/advisories/GHSA-rr25-4v34-pr7v
Negligible security impact

Search for package or bug name: Reporting problems