CVE-2020-5254

NameCVE-2020-5254
DescriptionIn NetHack before 3.6.6, some out-of-bound values for the hilite_statu ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs953978

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nethack (PTS)stretch3.6.0-4fixed
buster3.6.1-1vulnerable
sid3.6.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nethacksource(unstable)3.6.6-1953978
nethacksourcejessie(not affected)
nethacksourcestretch(not affected)

Notes

[buster] - nethack <no-dsa> (Minor issue)
[stretch] - nethack <not-affected> (Vulnerable code introduced in 3.6.1)
[jessie] - nethack <not-affected> (Vulnerable code introduced in 3.6.1)
https://github.com/NetHack/NetHack/security/advisories/GHSA-2ch6-6r8h-m2p9
https://nethack.org/security/CVE-2020-5254.html
Fixed with: https://github.com/NetHack/NetHack/commit/abdd3254ae06dd1fbcff637c4c631783d5ed9741 (NetHack-3.6.6_Released)
Introduced with: https://github.com/NetHack/NetHack/commit/f8211f69f2008609b59fe4c9ba341ff1fa520825 (NetHack-3.6.1_RC01)

Search for package or bug name: Reporting problems