CVE-2020-6061

NameCVE-2020-6061
DescriptionAn exploitable heap overflow vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4711-1
NVD severityhigh
Debian Bugs951876

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
coturn (PTS)stretch4.5.0.5-1+deb9u1vulnerable
stretch (security)4.5.0.5-1+deb9u2fixed
buster4.5.1.1-1.1vulnerable
buster (security)4.5.1.1-1.1+deb10u1fixed
bullseye, sid4.5.1.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
coturnsource(unstable)4.5.1.1-1.2951876
coturnsourcebuster4.5.1.1-1.1+deb10u1DSA-4711-1
coturnsourcejessie(not affected)
coturnsourcestretch4.5.0.5-1+deb9u2DSA-4711-1

Notes

[jessie] - coturn <not-affected> (Vulnerable code introduced later)
https://talosintelligence.com/vulnerability_reports/TALOS-2020-0984
https://github.com/coturn/coturn/commit/51a7c2b9bf924890c7a3ff4db9c4976c5a93340a

Search for package or bug name: Reporting problems