CVE-2020-7045

NameCVE-2020-7045
DescriptionIn Wireshark 3.0.x before 3.0.8, the BT ATT dissector could crash. This was addressed in epan/dissectors/packet-btatt.c by validating opcodes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch (security), stretch2.6.7-1~deb9u1vulnerable
buster2.6.8-1.1vulnerable
bullseye, sid3.2.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)3.2.0-1
wiresharksourcejessie(not affected)

Notes

[buster] - wireshark <postponed> (Can be fixed along in next 3.0.x DSA)
[stretch] - wireshark <postponed> (Can be fixed along in next DSA/update to 3.0)
[jessie] - wireshark <not-affected> (Doesn't support request-respone tracking in affected code passage, yet)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=16258
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=01f261de41f4dd3233ef578e5c0ffb9c25c7d14d
https://www.wireshark.org/security/wnpa-sec-2020-02.html

Search for package or bug name: Reporting problems