CVE-2020-7060

NameCVE-2020-7060
DescriptionWhen using certain mbstring functions to convert multibyte encodings, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause function mbfl_filt_conv_big5_wchar to read past the allocated buffer. This may lead to information disclosure or crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4626-1, DSA-4628-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1vulnerable
jessie (security)5.6.40+dfsg-0+deb8u8vulnerable
php7.0 (PTS)stretch7.0.33-0+deb9u6vulnerable
stretch (security)7.0.33-0+deb9u7fixed
php7.3 (PTS)buster7.3.11-1~deb10u1vulnerable
buster (security)7.3.14-1~deb10u1fixed
bullseye, sid7.3.15-3fixed
php7.4 (PTS)bullseye, sid7.4.3-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)
php7.0source(unstable)(unfixed)
php7.0sourcestretch7.0.33-0+deb9u7DSA-4628-1
php7.3source(unstable)7.3.15-1
php7.3sourcebuster7.3.14-1~deb10u1DSA-4626-1
php7.4source(unstable)7.4.2-7

Notes

Fixed in PHP 7.4.2, 7.3.14, 7.2.27
PHP Bug: http://bugs.php.net/79037

Search for package or bug name: Reporting problems