CVE-2020-7061

NameCVE-2020-7061
DescriptionIn PHP versions 7.3.x below 7.3.15 and 7.4.x below 7.4.3, while extracting PHAR files on Windows using phar extension, certain content inside PHAR file could lead to one-byte read past the allocated buffer. This could potentially lead to information disclosure or crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8fixed
stretch (security)7.0.33-0+deb9u12fixed
php7.3 (PTS)buster7.3.29-1~deb10u1fixed
buster (security)7.3.31-1~deb10u1fixed
php7.4 (PTS)bullseye (security)7.4.25-1+deb11u1fixed
bullseye, bookworm, sid7.4.21-1+deb11u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(not affected)
php7.0source(unstable)(not affected)
php7.3source(unstable)(not affected)
php7.4source(unstable)(not affected)

Notes

- php7.4 <not-affected> (Windows specific issue)
- php7.3 <not-affected> (Windows specific issue)
- php7.0 <not-affected> (Windows specific issue)
- php5 <not-affected> (Windows specific issue)
Fixed in PHP 7.4.3, 7.3.15
PHP Bug: https://bugs.php.net/79171

Search for package or bug name: Reporting problems