CVE-2020-7065

NameCVE-2020-7065
DescriptionIn PHP versions 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using mb_strtolower() function with UTF-32LE encoding, certain invalid strings could cause PHP to overwrite stack-allocated buffer. This could lead to memory corruption, crashes and potentially code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4719-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8fixed
stretch (security)7.0.33-0+deb9u10fixed
php7.3 (PTS)buster, buster (security)7.3.19-1~deb10u1fixed
php7.4 (PTS)bullseye, sid7.4.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(not affected)
php7.0source(unstable)(not affected)
php7.3sourcebuster7.3.19-1~deb10u1DSA-4719-1
php7.3source(unstable)(unfixed)
php7.4source(unstable)7.4.5-1

Notes

- php7.0 <not-affected> (Vulnerable code introduced later)
- php5 <not-affected> (Vulnerable code introduced later)
Fixed in PHP 7.4.4, 7.3.16
PHP Bug: https://bugs.php.net/79371
https://git.php.net/?p=php-src.git;a=commit;h=1fdffd1c55d771ca22ae217784ab75fce592ad38

Search for package or bug name: Reporting problems