CVE-2020-7066

NameCVE-2020-7066
DescriptionIn PHP versions 7.2.x below 7.2.29, 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using get_headers() with user-supplied URL, if the URL contains zero (\0) character, the URL will be silently truncated at it. This may cause some software to make incorrect assumptions about the target of the get_headers() and possibly send some information to a wrong server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2188-1, DSA-4717-1, DSA-4719-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8fixed
stretch (security)7.0.33-0+deb9u10fixed
php7.3 (PTS)buster, buster (security)7.3.19-1~deb10u1fixed
php7.4 (PTS)bullseye, sid7.4.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcejessie5.6.40+dfsg-0+deb8u11DLA-2188-1
php5source(unstable)(unfixed)
php7.0sourcestretch7.0.33-0+deb9u8DSA-4717-1
php7.0source(unstable)(unfixed)
php7.3sourcebuster7.3.19-1~deb10u1DSA-4719-1
php7.3source(unstable)(unfixed)
php7.4source(unstable)7.4.5-1

Notes

Fixed in PHP 7.4.4, 7.3.16, 7.2.29
PHP Bug: https://bugs.php.net/79329
https://git.php.net/?p=php-src.git;a=commit;h=0d139c5b94a5f485a66901919e51faddb0371c43

Search for package or bug name: Reporting problems