CVE-2020-7068

NameCVE-2020-7068
DescriptionIn PHP versions 7.2.x below 7.2.33, 7.3.x below 7.3.21 and 7.4.x below 7.4.9, while processing PHAR files using phar extension, phar_parse_zipfile could be tricked into accessing freed memory, which could lead to a crash or information disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2345-1, DSA-4856-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8vulnerable
stretch (security)7.0.33-0+deb9u10fixed
php7.3 (PTS)buster7.3.19-1~deb10u1vulnerable
buster (security)7.3.27-1~deb10u1fixed
php7.4 (PTS)bullseye7.4.15-1fixed
sid7.4.15-5+deb11u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.0sourcestretch7.0.33-0+deb9u9DLA-2345-1
php7.0source(unstable)(unfixed)
php7.3sourcebuster7.3.27-1~deb10u1DSA-4856-1
php7.3source(unstable)(unfixed)
php7.4source(unstable)7.4.9-1

Notes

Fixed in PHP 7.4.9, 7.3.21, 7.2.33
PHP Bug: https://bugs.php.net/79797
https://git.php.net/?p=php-src.git;a=commit;h=7355ab81763a3d6a04ac11660e6a16d58838d187

Search for package or bug name: Reporting problems