CVE-2020-7656

NameCVE-2020-7656
Descriptionjquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jquery (PTS)stretch3.1.1-2+deb9u1fixed
stretch (security)3.1.1-2+deb9u2fixed
buster3.3.1~dfsg-3+deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jquerysource(unstable)2.2.4+dfsg-1

Notes

[jessie] - jquery <ignored> (Too intrusive to backport)
https://snyk.io/vuln/SNYK-JS-JQUERY-569619
See debian-lts discussion starting at: https://lists.debian.org/debian-lts/2020/06/msg00025.html

Search for package or bug name: Reporting problems