CVE-2020-7673

NameCVE-2020-7673
Descriptionnode-extend through 0.2.0 is vulnerable to Arbitrary Code Execution. User input provided to the argument `A` of `extend` function`(A,B,as,isAargs)` located within `lib/extend.js` is executed by the `eval` function, resulting in code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-extend (PTS)stretch2.0.0-1fixed
bullseye, sid, buster3.0.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-extendsource(unstable)(not affected)

Notes

- node-extend <not-affected> (Vulnerable code not present)
Debian's node-extend is a different package(fork?) which doesn't eval()

Search for package or bug name: Reporting problems