CVE-2020-7774

NameCVE-2020-7774
DescriptionThis affects the package y18n before 3.2.2, 4.0.1 and 5.0.5. PoC by po6ix: const y18n = require('y18n')(); y18n.setLocale('__proto__'); y18n.updateLocale({polluted: true}); console.log(polluted); // true
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs976390

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-y18n (PTS)stretch3.2.1-2vulnerable
buster3.2.1-2+deb10u1fixed
bullseye, sid4.0.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-y18nsourcebuster3.2.1-2+deb10u1
node-y18nsource(unstable)4.0.0-3976390

Notes

[stretch] - node-y18n <no-dsa> (Minor issue)
https://snyk.io/vuln/SNYK-JS-Y18N-1021887
https://github.com/yargs/y18n/issues/96
https://github.com/yargs/y18n/pull/108

Search for package or bug name: Reporting problems