CVE-2020-8164

NameCVE-2020-8164
DescriptionA deserialization of untrusted data vulnerability exists in rails < 5.2.4.3, rails < 6.0.3.1 which can allow an attacker to supply information can be inadvertently leaked fromStrong Parameters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2251-1, DLA-2282-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)stretch2:4.2.7.1-1+deb9u2vulnerable
stretch (security)2:4.2.7.1-1+deb9u3fixed
buster2:5.2.2.1+dfsg-1+deb10u1vulnerable
bullseye2:5.2.4.3+dfsg-2fixed
sid2:6.0.3.2+dfsg-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssourceexperimental2:6.0.3.1+dfsg-1
railssourcejessie2:4.1.8-1+deb8u7DLA-2251-1
railssourcestretch2:4.2.7.1-1+deb9u3DLA-2282-1
railssource(unstable)2:5.2.4.3+dfsg-1

Notes

https://weblog.rubyonrails.org/2020/5/18/Rails-5-2-4-3-and-6-0-3-1-have-been-released
https://github.com/rails/rails/commit/7a3ee4fea90b7555f8d09c6c05c15fe7ab5a06ec

Search for package or bug name: Reporting problems