CVE-2020-8287

NameCVE-2020-8287
DescriptionNode.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 allow two copies of a header field in an HTTP request (for example, two Transfer-Encoding header fields). In this case, Node.js identifies the first header field and ignores the second. This can lead to HTTP Request Smuggling.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4826-1
NVD severitymedium
Debian Bugs979364

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)stretch4.8.2~dfsg-1vulnerable
buster, buster (security)10.24.0~dfsg-1~deb10u1fixed
bullseye, sid12.21.0~dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssourcebuster10.23.1~dfsg-1~deb10u1DSA-4826-1
nodejssource(unstable)12.20.1~dfsg-1979364

Notes

[stretch] - nodejs <ignored> (Nodejs in stretch not covered by security support)
https://nodejs.org/en/blog/release/v10.23.1/
https://github.com/nodejs/node/commit/fc70ce08f5818a286fb5899a1bc3aff5965a745e (v10.23.1)

Search for package or bug name: Reporting problems