CVE-2020-8631

NameCVE-2020-8631
Descriptioncloud-init through 19.4 relies on Mersenne Twister for a random password, which makes it easier for attackers to predict passwords, because rand_str in cloudinit/util.py calls the random.choice function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2113-1
NVD severitylow
Debian Bugs951362

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cloud-init (PTS)jessie0.7.6~bzr976-2vulnerable
jessie (security)0.7.6~bzr976-2+deb8u1fixed
stretch0.7.9-2vulnerable
buster18.3-6vulnerable
bullseye, sid20.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cloud-initsource(unstable)19.4-2951362
cloud-initsourcejessie0.7.6~bzr976-2+deb8u1DLA-2113-1

Notes

[buster] - cloud-init <no-dsa> (Minor issue)
[stretch] - cloud-init <no-dsa> (Minor issue)
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1860795
https://github.com/canonical/cloud-init/pull/204

Search for package or bug name: Reporting problems