CVE-2020-8865

NameCVE-2020-8865
DescriptionThis vulnerability allows remote attackers to execute local PHP files on affected installations of Horde Groupware Webmail Edition 5.2.22. Authentication is required to exploit this vulnerability. The specific flaw exists within edit.php. When parsing the params[template] parameter, the process does not properly validate a user-supplied path prior to using it in file operations. An attacker can leverage this in conjunction with other vulnerabilities to execute code in the context of the www-data user. Was ZDI-CAN-10469.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs955019

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-horde-trean (PTS)jessie1.1.1-2vulnerable
stretch1.1.7-1vulnerable
buster1.1.9-3vulnerable
bullseye, sid1.1.9-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-horde-treansource(unstable)(unfixed)955019

Notes

[buster] - php-horde-trean <no-dsa> (Minor issue)
[stretch] - php-horde-trean <no-dsa> (Minor issue)
[jessie] - php-horde-trean <no-dsa> (Minor issue)
https://lists.horde.org/archives/announce/2020/001286.html
https://www.zerodayinitiative.com/advisories/ZDI-20-276/
https://github.com/horde/trean/commit/db0714a0c04d87bda9e2852f1b0d259fc281ca75
https://github.com/horde/trean/commit/055029f551501803d7e293a48316e2cf31307908

Search for package or bug name: Reporting problems