CVE-2020-8927

NameCVE-2020-8927
DescriptionA buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
brotli (PTS)stretch0.5.2+dfsg-2vulnerable
buster1.0.7-2vulnerable
bullseye, sid1.0.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
brotlisource(unstable)1.0.9-1

Notes

https://github.com/google/brotli/commit/223d80cfbec8fd346e32906c732c8ede21f0cea6

Search for package or bug name: Reporting problems